Написать программу в паскале Пользователь вводит количество дней, указывает процент скидки и вводит сумму. Рассчитать прибыль, если за каждый день сумма увеличивается на 3 $ и затем применяется скидка, то есть итоговая сумма е...

Написать программу в паскале Пользователь вводит количество дней, указывает процент скидки и вводит сумму. Рассчитать прибыль, если за каждый день сумма увеличивается на 3 $ и затем применяется скидка, то есть итоговая сумма еще увеличивается на данное число процентов.
Гость
Ответ(ы) на вопрос:
Гость
program zzz; var days:integer; var discount, sum:real; var days2:integer; begin   readln(days, discount, sum);   days2 := 0;   sum := 0;   discount := discount / 10;   while( days2 <= days ) do begin     sum := sum + (sum * discount); {я не до конца понял задание, посему, скорее всего, придется тут менять}     sum := sum + 3;     days2 := days2 + 1;   end;   writeln('Ответ: ', sum); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы