Написать программу в паскале реализующуу работу меню содержащих следующие пункты: 1 Вычесление суммы цыфр числа N; 2 вывод на экран таблицы квадратов первого десятка; 3 Дано число N. Определить его четность; 4 Выход.
Написать программу в паскале реализующуу работу меню содержащих следующие пункты: 1 Вычесление суммы цыфр числа N; 2 вывод на экран таблицы квадратов первого десятка; 3 Дано число N. Определить его четность; 4 Выход.
Ответ(ы) на вопрос:
program menu;
uses crt;
var m, i: integer;
n, z, x, b: longint;
begin
Writeln('Выберете пункт меню:');
Writeln('[1]Вычисление суммы цыфр числа N');
Writeln('[2]Вывод на экран таблицы квадратов первого десятка');
Writeln('[3]Дано число N. Определить его четность');
Writeln('[4]Выход');
read(m);
case m of 1:
begin
clrscr;
writeln('Введите число N:');
read(n);
x := 10;
z := n mod x;
while n div x > 0 do
begin
b := x;
x := x * 10;
z := z + n mod x div b;
end;
Writeln('Ответ: ', z);
end;
2: begin
clrscr;
for i := 1 to 10 do
begin
writeln('Квадрат ', i, ' = ', sqr(i));
end;
end;
3: begin
clrscr;
writeln('Введите число N:');
read(n);
if (n mod 2 ) = 0 then writeln('Число ', n, ' четное.') else writeln('Число ', n, ' не четное.');
end;
4: exit; end;
end.
Не нашли ответ?
Похожие вопросы