Написать программу вычисления среднеарифметического последовательно вводимых целых чисел, пропуская отрицательные, с окончанием по вводу признака конца.
Написать программу вычисления среднеарифметического последовательно вводимых целых чисел, пропуская отрицательные, с окончанием по вводу признака конца.
Ответ(ы) на вопрос:
Гость
var a,b,k,s:integer;
Begin
writeln ('Сколько всего будет чисел?');
readln (a);
writeln ('Вводите числа по одному через enter');
for b:=1 to a do
begin
readln (k);
if k>0 then S:=S+k;
end;
writeln(S/a);
end.
Не нашли ответ?
Похожие вопросы