Написать программу «Выделение цифр в записи числа» Дано трехзначное число. Определить, является ли сумма его цифр кратна 3 и 5.
Написать программу «Выделение цифр в записи числа» Дано трехзначное число. Определить, является ли сумма его цифр кратна 3 и 5.
Ответ(ы) на вопрос:
var a,s,n:integer; begin repeat write ('A =');readln(a); until (a>=100) and (a<=999); n:=a; while n div 10 <> 0 do begin n:=a; s:=s+a mod 10; a:=a div 10; end; if (s mod 3 = 0) or (s mod 5 = 0) then writeln ('Yes') else writeln ('No'); readln; end.
Не нашли ответ?
Похожие вопросы