Написать программу,которая запрашивает с клавиатуры четырехзначное число и сравнивает в нём первую и последнюю цифры, вторую и третью цифры. Если первая цифра равна четвёртой, а третья второй, то выводит на экран "Палиндорм", а...

Написать программу,которая запрашивает с клавиатуры четырехзначное число и сравнивает в нём первую и последнюю цифры, вторую и третью цифры. Если первая цифра равна четвёртой, а третья второй, то выводит на экран "Палиндорм", а в противном случае "не Палиндорм".
Гость
Ответ(ы) на вопрос:
Гость
var   a:integer; begin   write('Введите число ');   readln(a);   if (a div 1000 = a mod 10) and ((a div 100)mod 10 =(a div 10)mod 10)then   writeln('Палиндром')   else writeln('не Палиндром'); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы