Напишите пожалуйста на языке С++! 1) Пользователь отвечает на вопрос программы: «Сколько Вам лет» (0 стоит учесть, что для разных чисел используются разные склонения, например, «32 года», «99 лет» и т.п. 2) Написать программу, ...

Напишите пожалуйста на языке С++! 1) Пользователь отвечает на вопрос программы: «Сколько Вам лет» (0 стоит учесть, что для разных чисел используются разные склонения, например, «32 года», «99 лет» и т.п. 2) Написать программу, которая спрашивает у пользователя возраст, и выдает информацию о том, является ли он совершеннолетним. Учесть некорректный ввод возраста. 3) Ввести с клавиатуры целое число. Определить четное оно, или нечетное. 4) Решить следующие задачи: Является ли треугольник с длинами сторон a, b, c : - прямоугольным; - равнобедренным; - равносторонним. Стороны вводятся с клавиатуры.
Гость
Ответ(ы) на вопрос:
Гость
1) #include using namespace std; int main() {   cout << "Сколько Вам лет?" << endl;   int age;   string s;   cin >> age >> s; } 2) #include using namespace std; int main() {   cout << "Сколько Вам лет?" << endl;   int age;   cin >> age;   if(age < 0) cout << "wrong" << endl;   else if(age >= 18) cout << "yes" << endl;   else cout << "no" << endl; } 3) #include using namespace std; int main() {  int a;  cin >> a  if(a%2 == 0) cout << "четное" << endl;  else cout << "нечетное" << endl; } 4) #include using namespace std; int main() {  int a,b,c;  string s = "";  cin >> a >> b >> c;  if(a == b && a == c) cout << "равносторонний" << endl;  else {     if (a==b || a == c || b == c) s += "равнобедренный";     if( a*a == (b*b+c*c) || b*b == (a*a+c*c) || c*c == (a*a+b*b))            s+= "прямоугольный";     if(s == '') cout << "обычный" << endl;     else cout << s << endl;   } }    
Не нашли ответ?
Ответить на вопрос
Похожие вопросы