Напишите программу для заштрихованной области графика на языке Pascal var x,y: real; begin read (x,y); if .........
Напишите программу для заштрихованной области графика на языке Pascal
var x,y: real;
begin
read (x,y);
if .........
Ответ(ы) на вопрос:
var
x,y:real;
b:boolean;
begin
read(x,y);
if sqr(x)+sqr(y)<=1 then
if x<=0 then b:=((y>=0) and (y<=-x) or (y<=x))
else b:=((y<=0) and(y>=-x) or (y>=x))
else b:=False;
if b then Writeln('Точка попадает в область или лежит на границе')
else Writeln('Точка не попадает в область и не лежит на границе')
end.
Не нашли ответ?
Похожие вопросы