Напишите программу, которая находит путь в лабиринте между заданными клетками. Сведения о лабиринте (размеры, расположение стенок, координаты начальной и целевой клеток) записаны в файле input.txt . Требуется найти и вывести дл...
Напишите программу, которая находит путь в лабиринте между заданными клетками. Сведения о лабиринте (размеры, расположение стенок, координаты начальной и целевой клеток) записаны в файле input.txt . Требуется найти и вывести длину кратчайшего маршрута между заданными начальной и целевой клетками. Входные данные В первой строке файла input.txt записаны через пробел размеры карты лабиринта: количество строк N и количество столбцов M ( 1 ≤ N , M ≤ 100 ). Далее в отдельной строке через пробел записаны координаты начальной клетки, сначала строка, потом столбец (нумерация с единицы!). В следующей строке в таком же формате записаны координаты целевой клетки, в которую нужно придти. В следующих N строках записана карта лабиринта. Каждая строка состоит из M символов, каждый символ – это '.' (клетка свободна) или 'X' (клетка непроходима). Выходные данные Программа должна вывести одно число – длину кратчайшего маршрута из начальной клетки лабиринта в целевую. Если таких маршрутов нет, нужно вывести число -1.
Примеры входные данные
6 7
1 2
2 6
....X..
.XXXX..
....X..
....X..
XX.XX.X
......X
выходные данные
15
Ответ(ы) на вопрос:
Гость
{неэффективный алгоритм}
const
k = 100;
type
maze = array [1..k, 1..k] of integer;
var
l : maze;
n, m: integer;
i, j: integer;
c: char;
t: text;
w: integer;
x0, y0: integer;
x1, y1: integer;
procedure ways(a,b,r:integer);
begin
if (w = 0) or (r < w) then {нет смысла идти дальше, если текущий путь уже превосходит найденный}
if (l[a,b] <> -2) then
if (r < l[a,b]) or (l[a,b] = -1) then {нет смысла идти, если текущая клетка уже была достигнута за меньшее число шагов}
begin
l[a,b] := r;
if (a = x1) and (b = y1) then
w := r
else
begin
if a <> 1 then ways(a - 1, b, r + 1);
if b <> 1 then ways(a, b - 1, r + 1);
if a <> n then ways(a + 1, b, r + 1);
if b <> m then ways(a, b + 1, r + 1);
end
end;
end;
begin
assign(t, 'input.txt');
reset(t);
w := 0;
readln(t, n, m);
readln(t, x0, y0);
readln(t, x1, y1);
for i := 1 to n do
begin
for j := 1 to m do
begin
read(t, c);
case c of
'.' : l[i,j] := -1; {будем считать, что если клетка отмечена как -1, то путь к ней еще не найден}
'X' : l[i,j] := -2; {-2, если клетка непроходима}
end;
end;
readln(t)
end;
close(t);
if (l[x0,y0] <> -2) and (l[x1,y1] <> -2) then
begin
l[x0,y0] := 1; {просто трюк, чтобы пройти проверку на (r < l[x0,y0])}
ways(x0, y0, 0);
end
else
l[x1,y1] := -1;
writeln(l[x1,y1])
end.
Не нашли ответ?
Похожие вопросы