Напишите программу, которая получает с клавиатуры натуральное число и находит наибольшую цифру в его десятичной записи. Напишите программу, которая получает с клавиатуры натуральное число и определяет, есть ли в его десятично...

Напишите программу, которая получает с клавиатуры натуральное число и находит наибольшую цифру в его десятичной записи. Напишите программу, которая получает с клавиатуры натуральное число и определяет, есть ли в его десятичной записи одинаковые цифры, стоящие рядом. Паскаль!!!
Гость
Ответ(ы) на вопрос:
Гость
Var N,A:integer; Begin Write('N = ');Read(N); A:=0; While N>0 do    Begin    if (N mod 10) > A then A:= N mod 10;    N:=N div 10;    End; Write(A) End. Var N,A,B:integer; C:boolean; Begin Write('N = ');Read(N); A:=-1; B:=-2; C:=false; While N>0 do    Begin    if A=B then C:=true;    if N>0 then       Begin       A:=N mod 10;       N:=N div 10;       End;    if A=B then C:=true;    if N>0 then       Begin       B:=N mod 10;       N:=N div 10;       End;    End; if A=B then C:=true; if C then Write('Есть') else Write('Нет') End.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы