Напишите программу, которая считывает с клавиатуры строку S и определяет, встречаются ли в строке S слова палиндромы. Словом считается последовательность символов, ограниченная проьелами, и не имеющая пробелов внутри себя. Стро...

Напишите программу, которая считывает с клавиатуры строку S и определяет, встречаются ли в строке S слова палиндромы. Словом считается последовательность символов, ограниченная проьелами, и не имеющая пробелов внутри себя. Строка S не пустая, содержит не более 200 символов и состоит только из строчных и прописных букв латинского алфавита и пробелов
Гость
Ответ(ы) на вопрос:
Гость
var  s,t:string;  n,i:integer; begin write('Введите строку: '); readln(t); n:=1; t:=t+' '; for i:=2 to length(t) do   if ((t[i]=' ') or (i=length(t)))  and (i-n>1) then     begin     s:=Copy(t,n,i-n);     if s=ReverseString(s) then       begin       writeln('Да, палиндромы есть');       halt       end         else n:=i+1     end; writeln('Палиндромов нет')     end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы