Напишите программу, которая в последовательности целых чисел находит сумму и количество чисел, кратных 17, или сообщает, что таких чисел нет. На вход программы подаются целые числа, количество введенных чисел неизвестно, послед...

Напишите программу, которая в последовательности целых чисел находит сумму и количество чисел, кратных 17, или сообщает, что таких чисел нет. На вход программы подаются целые числа, количество введенных чисел неизвестно, последовательность заканчивается числом 0 (0 - признак окончания ввода, не является членом последовательности). Количество чисел не превышает 100. Введенные числа по модулю не превышают 300. Программа должна вывести сумму и количество чисел, кратных 17, или вывести NO, если таких числе в последовательности нет
Гость
Ответ(ы) на вопрос:
Гость
var summa,count,numb :integer; begin summa:=0; count:=0; readln(numb); while numb <> 0 do begin if numb mod 17 = 0 then begin summa:=summa+numb; count:=count+1; end; readln(numb); end; if (summa > 0) and (count > 0) then writeln(summa,'  ',count) else  writeln('No'); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы