Напишите программу которая вычисляет сумму отрицательных элементов массива A[20]. Массив заполнить случайными числами из [-1000; 1000]
Напишите программу которая вычисляет сумму отрицательных элементов массива A[20].
Массив заполнить случайными числами из [-1000; 1000]
Ответ(ы) на вопрос:
program Project2;
{$APPTYPE CONSOLE}
uses SysUtils,windows;constnMin=1;nMax=20;typemas=array[nMin..Nmax] of integer;
Vara:mas; i:integer;s:real;begin setconsoleCP(1251); setconsoleOutPutCp(1251); randomize;
for i:=1 to nMax doa[i]:=random(1000)-500;writeln ('Ìàññèâ:'); for i:=1 to nMax do beginwrite ('');write (a[i]:2);writeln ('');end;s:=0;for i:=1 to Nmax dobeginIf a[i]<0 thens:=s+a[i];end;writeln ('Ñóììà îòðèöàòåëüíûõ ýëåìåíòîâ ìàññèâà = ',s:2:2);readln;end.
Не нашли ответ?
Похожие вопросы