Напишите программу на ABC паскале которая вычисляет сумму всех чётных чисел в диапазоне от 1 до n

Напишите программу на ABC паскале которая вычисляет сумму всех чётных чисел в диапазоне от 1 до n
Гость
Ответ(ы) на вопрос:
Гость
var n,a,z,x:integer; begin z:=0; readln(n); for x:=1 to n do if x mod 2=0 then begin x:=x+z; a:=a+x; end; write(a,' '); end.
Гость
program z; var n,i,s:integer; begin write('n='); readln(n); for i:=1 to n do if i mod 2 = 0 then s:=s+i; write('Сумма = ',s); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы