Напишите программу на pascal, вычисляющую факториал введенного числа n!!!
Напишите программу на pascal, вычисляющую факториал введенного числа n!!!
Ответ(ы) на вопрос:
Гость
program z1;
uses crt;
var n, i, s: integer;
begin
read(n);
s := 1;
for i := 1 to n do
s := s * i;
writeln(s);
end.
Гость
{}
var
n : byte;
function fact (a: byte): uint64;
var pz : uint64;
i : byte;
begin
pz:=1;
for i:=1 to a do pz:=pz*i;
fact:=pz;
end;
begin
repeat
write ('Введите n : ');
readln (n);
until n in [0..20];
write ('n! = ', fact(n));
end.
Не нашли ответ?
Похожие вопросы