Напишите программу на Паскале. Дан массив положительных и отрицательных чисел. Вычислить сумму положительных и произведение отрицательных чисел. А[1..10]
Напишите программу на Паскале.
Дан массив положительных и отрицательных чисел. Вычислить сумму положительных и произведение отрицательных чисел.
А[1..10]
Ответ(ы) на вопрос:
Гость
const m=10;
var
a:array[1..m] of integer;
i,sum,proz:integer;
begin
sum:=0;
proz:=1;
for i:=1 to m do
begin
read(a[i]);
if a[i]>0 then
sum:=sum+a[i]
else
ifa[i]<0 then
proz:=proz*a[i];
end;
writeln('Сумма положительных чисел= ',sum,' Произведение отрицательных чисел= ',proz);end.
Не нашли ответ?
Похожие вопросы