Напишите программу на Паскале.Для заданных чисел X и N вычислите Z=X^N=X*X...X.X*X...X=N
Напишите программу на Паскале.Для заданных чисел X и N вычислите Z=X^N=X*X...X.
X*X...X=N
Ответ(ы) на вопрос:
Гость
var
x,n,x1 : real;
begin
readln(x,n);
x1:=abs(x);
if x<0 then writeln(-1*exp(n*ln(x1)):0:0)
else writeln(exp(n*ln(x)):0:0);
end.
Не нашли ответ?
Похожие вопросы