Напишите программу на паскале,которая будет сообщать можно ли попасть в цель находящая на заданном расстоянии L на высоте h над уровнем горизонта при заданном угле d и начальной скорости V0.В ответе должен высчитаться угол и на...
Напишите программу на паскале,которая будет сообщать можно ли попасть в цель находящая на заданном расстоянии L на высоте h над уровнем горизонта при заданном угле d и начальной скорости V0.В ответе должен высчитаться угол и написать программа "попал" ты или нет
Ответ(ы) на вопрос:
Гость
Чтобы наш снаряд (пуля, мяч или что-то еще) попало в цель, нужно чтобы высота подъема снаряда совпала с высотой, на которой расположена цель, и чтобы дальность полета совпала с заданным расстоянием. Иначе снаряд может улететь выше или ниже цели или не долетать. Воспользуемся формулами по равнозамедленному движению.
program zadacha; const g=9.8; var h,L,a,V,S,h1:real; begin writeln('vvedite visotu i dalnost celi'); readln(h,L); writeln('vvedite ugol, skorost snariada'); readln(a,V); a:=a*pi/180; h1:=int(( sqr(V)* sqr(sin(a))) / (2*g)); S:=int((sqr(V)*sin(2*a))/g); if (S=L) and (h1=h) then writeln('popal') else writeln('ne popal'); end.
Не нашли ответ?
Похожие вопросы