Напишите программу на языке Паскаль для нахождение количества цифр в записи положительного целого числа x.

Напишите программу на языке Паскаль для нахождение количества цифр в записи положительного целого числа x.
Гость
Ответ(ы) на вопрос:
Гость
program ololo; var a,b:integer; begin read(a); if a = 0 then begin write(1); exit; end; while a <> 0 do begin   inc(b);   a := a div 10; end; write(b); end.
Гость
Вот так гораздо проще. var s:string; begin readln(s); writeln(length(s)); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы