Напишите программу на языке Паскаль. ____________________________________________ Скорость лодки в стоячей воде Vл км/ч, скорость течения реки Vр км/ч (Vр меньше Vл). Время движения лодки по озеру Т1 ч, а по реке (против теч...

Напишите программу на языке Паскаль. ____________________________________________ Скорость лодки в стоячей воде Vл км/ч, скорость течения реки Vр км/ч (Vр < Vл). Время движения лодки по озеру Т1 ч, а по реке (против течения) — Т2 ч. Определить путь S, пройденный лодкой. _________________________________________ Добавлю 10, если будет без ошибок.
Гость
Ответ(ы) на вопрос:
Гость
var vl,vr,t1,t2:real; begin   writeln('Скорость лодки в стоячей воде и скорость течения');   readln (vl,vr);   writeln('Время движения по озеру и против течения');   readln (t1,t2);   writeln('Общий путь судна:', vl*t1+(vl-vr)*t2); end. Тестовое решение: Скорость лодки в стоячей воде и скорость течения 10 3 Время движения по озеру и против течения 2 3 Общий путь судна:41
Гость
var v1,v2,t1,t2,s1,s2,so:integer; begin v1:=0; v2:=0; while (v2>=v1) do begin  writeln('введите скорость лодки');  readln(v1);  writeln('введите скорость течения реки');  readln(v2);  if (v2>=v1) then writeln('введены неправильные данные');  end;  writeln('введите время движения лодки по озеру');  readln(t1);  writeln('введите время движения лодки по реке против течения');  readln(t2);   s1:=v1*t1;  s2:=(v1-v2)*t2;  so:=s1+s2;  writeln('длина общего пути ',so); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы