Напишите программу Паскаль для задач: 1)найти сумму и произведение натурального ряда от 1 до 10. 2)Дано натурально число n.Вычислить 2 в n степени. 3)Дано натуральное число n.Чему равна сумма его цифр?
Напишите программу Паскаль для задач:
1)найти сумму и произведение натурального ряда от 1 до 10.
2)Дано натурально число n.Вычислить 2 в n степени.
3)Дано натуральное число n.Чему равна сумма его цифр?
Ответ(ы) на вопрос:
Гость
program n1;
var a,b,sum,pr:integer;
begin
sum:=0;
pr:=1;
for a:=1 to 10 do begin
sum:=sum+a;
end;
writeln('сумма чисел от 1 до 10 = ',sum);
for a:=1 to 10 do begin
pr:=pr*a;
end;
writeln('произведение чисел от 1 до 10 = ',pr);
end.
program n2;
var a,b,n:integer;
begin
writeln('введите степень n');
readln(n);
b:=1;
for a:=1 to n do begin
b:=b*2;
end;
writeln('2 в ',n,' степени = ', b);
end.
program n3;
var sum,a,n,n2:integer;
begin
writeln('введите число n');
readln(n);
n2:=n;
while n<>0 do begin
a:=n mod 10;
sum:=a+sum;
n:=n div 10;
end;
writeln('сумма цифр ',n2,' = ',sum);
end.
Не нашли ответ?
Похожие вопросы