Напишите программу пожалуйста Ввести одномерный массив A из 13 элементов. Определить в нём среднее арифметическое тех элементов, которые при делении на 4 дают остаток 1 или 3.

Напишите программу пожалуйста Ввести одномерный массив A из 13 элементов. Определить в нём среднее арифметическое тех элементов, которые при делении на 4 дают остаток 1 или 3.
Гость
Ответ(ы) на вопрос:
Гость
begin S:=0; n:=0; for i:=1 to 13 do begin    readln (A[i]); end; for i:=1 to 13 do begin    if (A[i] mod 4 = 1) or (A[i] mod 4 = 3) then begin S:=S+A[i]; n:=n+1; end;    end; writeln (S/n); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы