Напишите программу в паскаль  для решения следующей задачи: для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если первое из них отрицательно, а второе вдвое больше третьего, ...

Напишите программу в паскаль  для решения следующей задачи: для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если первое из них отрицательно, а второе вдвое больше третьего, то выведите среднее арифметическое всех четырех чисел. Если произведение этих четырех чисел больше их суммы, то выведите эти сумму и произведение. Если выполняются одновременно два перечисленных выше условия, то выведите среднее арифметическое этих чисел, их произведение и сумму. Иначе, выведите удвоенные значения этих чисел.
Гость
Ответ(ы) на вопрос:
Гость
var a,b,c,d:real; begin readln(a,b,c,d);i f (a<0) and (b/c=2) then begin writeln((a+b+c+d)/4); if a*b*c*b>a+b+c+d then  begin writeln(a*b*c*b); writeln(a+b+c+d); end; end else writeln(a*2,' ',b*2,' ',c*2,' ',d*2); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы