Напишите программу ( в паскале авс), которая вычисляет число пи с заданной пользователем точностью. Воспользуйтесь данными и условием предыдущей задачи. (условие предыдущей задачи: Напишите программу, которая вычисляет частичну...

Напишите программу ( в паскале авс), которая вычисляет число пи с заданной пользователем точностью. Воспользуйтесь данными и условием предыдущей задачи. (условие предыдущей задачи: Напишите программу, которая вычисляет частичную сумму ряда 1-1/3+1/5-1/7+1/9-... и сравнивает полученное значение с пи/4).
Гость
Ответ(ы) на вопрос:
Гость
var s,sgn,eps: real;     i: integer; begin   write('точность вычислений: ');   readln(eps);   s:=1;  sgn:= -1;   i:=3;   repeat     s:=s+sgn/ i;     sgn:= - sgn;     i:=i+2;   until 8/i
Не нашли ответ?
Ответить на вопрос
Похожие вопросы