Напишите программу в паскале: найти сумму членов арифметической прогрессии , если известны ее первый член,разность и число членов прогрессии.
Напишите программу в паскале: найти сумму членов арифметической прогрессии , если известны ее первый член,разность и число членов прогрессии.
Ответ(ы) на вопрос:
program SAP;
var
S, d: integer;
i, N: byte;
a: array[1..255] of integer;
begin
write('Введите первый член арифметической прогрессии: ');
readln(a[1]);
write('Введите разность арифметической прогрессии: ');
readln(d);
write('Введите количество членов арифметической прогрессии: ');
readln(N);
for i:= 2 to N do begin
a[i]:= a[1] + (i - 1) * d;
S:= S + a[i]
end;
writeln('Сумма членов арифметической прогрессии: ', S);
end.
var a,b,c,k:real;
begin;
write('Введите первое число прогрессии:');
readln(a);
write('Введите разность прогрессии:');
readln(b);
write('Введите число членов прогрессии:');
readln(c);
k:=((2*a+b*(c-1))/2)*c;
writeln(k);
end.
Не нашли ответ?
Похожие вопросы