Напишите программу вычисления наименьшего общего кратного следующих четырех чисел:36,54,18 и 15.Используйте процедуру вычисления наибольшего общего делителя двух чисел.
Напишите программу вычисления наименьшего общего кратного следующих четырех чисел:36,54,18 и 15.Используйте процедуру вычисления наибольшего общего делителя двух чисел.
Ответ(ы) на вопрос:
Гость
// PascalABC.NET 3.2, сборка 1363 от 17.12.2016
// Внимание! Если программа не работает, обновите версию!
function gcd(a,b:int64):int64; // НОД
begin
while b<>0 do begin a:=a mod b; Swap(a,b) end;
Result:=a
end;
begin
Writeln(gcd(gcd(36,54),gcd(18,15)))
end.
Результат
3
Не нашли ответ?
Похожие вопросы