Напишите программу, вычисляющую значение функции y={ -1 при х меньше 0 y={0 при х=0 y={1 при х меньше 0
Напишите программу, вычисляющую значение функции
y={ -1 при х<0
y={0 при х=0
y={1 при х<0
Ответ(ы) на вопрос:
Гость
Это определение стандартной неэлементарной кусочно-постоянной математической функции sgn(x) - сигнум От латинского signum - знак).
В языке Паскаль эта функция уже определена.
// PascalABC.NET 3.1, сборка 1239 от 08.05.2016
// Также проверено в WDE: http://pascalabc.net/WDE
begin
Writeln('y=',Sign(ReadReal('x=')))
end.
Тестовое решение
x= 4.564
y=1
Не нашли ответ?
Похожие вопросы