Напишите программу:даны действительные числа a b c.если нельзя построить треугольник с такими сторонами то напечатать 0,иначе 3,2 или 1 в зависимости от того,равносторонний этот треугольник ,равнобедренный или какой-либо другой.

Напишите программу:даны действительные числа a b c.если нельзя построить треугольник с такими сторонами то напечатать 0,иначе 3,2 или 1 в зависимости от того,равносторонний этот треугольник ,равнобедренный или какой-либо другой.
Гость
Ответ(ы) на вопрос:
Гость
var a,b,c : real; begin write('a='); readln(a); write('b='); readln(b); write('c='); readln(c); if (a+b<=c)or(a+c<=b)or(b+c<=a)  then writeln(0)  else if (a<>b)and(b<>c)and(a<>c)         then writeln(1)         else if (a<>b)or(b<>c) then writeln(2)                                else writeln(3); end. Пример: a=3 b=3 c=4 2
Не нашли ответ?
Ответить на вопрос
Похожие вопросы