Напишите программу(Pascal) Найдите сумму всех вводимых с клавиатуры чисел, кратных заданному числу а.

Напишите программу(Pascal) Найдите сумму всех вводимых с клавиатуры чисел, кратных заданному числу а.
Гость
Ответ(ы) на вопрос:
Гость
Program n1; var sum,a,c: integer; begin readln(a); sum:=0; while true do begin readln(c); if c=0 then break; if c mod a=0 then sum:=sum+c; end; writeln(sum); end.
Гость
Предполагается, что ввод завершает число 0 // PascalABC.NET 3.2, сборка 1385 от 14.02.2017 // Внимание! Если программа не работает, обновите версию! begin   var a:=ReadInteger('a=');   Writeln(ReadSeqIntegerWhile(x->x<>0).Where(x->x mod a=0).Sum) end. Пример a= 2 5 7 12 8 -4 3 11 0 16
Не нашли ответ?
Ответить на вопрос
Похожие вопросы