Народ, хелп! Нужно написать программу, которая по введенным координатам проверяет, лежит ли точка в выделенной области. В идеале - программа на Python, но можно и на Pascal.
Народ, хелп! Нужно написать программу, которая по введенным координатам проверяет, лежит ли точка в выделенной области. В идеале - программа на Python, но можно и на Pascal.
Ответ(ы) на вопрос:
Гость
//PascalABC.NET 3.2 сборка 1318
Var
x,y:integer;
begin
readln(x,y);
if ((x>0) and (y<=0) and (y>=sqr(x)-2)) or ((x<0) and (y<=-x) and (y>=sqr(x)-2)) or ((x=0) and (y>=-2) and (y<=0)) then writeln('Принадлежит') else writeln('Не принадлежит');
end.
Не нашли ответ?
Похожие вопросы