Не могу составить программу, уже весь мозг перевернул, помогите через Pascal Присвоить целой переменной d четвертую от конца цифру в записи положительного целого числа x (например, если x=34517, то d=4)
Не могу составить программу, уже весь мозг перевернул, помогите через Pascal
Присвоить целой переменной d четвертую от конца цифру в записи
положительного целого числа x (например, если x=34517, то d=4)
Ответ(ы) на вопрос:
program Project;
uses
crt;
var
x,d: integer;
begin
clrscr;
write('x=');
readln(x);
d:=(x div 1000) mod 10;
writeln('d=',d);
end.
Не нашли ответ?
Похожие вопросы