Нужно очень срочно решить данные задачи. Буду очень признателен.    1. Составьте программу ввода и вывода массива: 3,4,-9,8,1,-6,2,-5,-1,7,5,9. 2. Составьте блок-схему алгоритма и программу вычисления в массиве А(10) количества...

Нужно очень срочно решить данные задачи. Буду очень признателен.    1. Составьте программу ввода и вывода массива: 3,4,-9,8,1,-6,2,-5,-1,7,5,9. 2. Составьте блок-схему алгоритма и программу вычисления в массиве А(10) количества отрицательных эллементов. 3. Составьте программу вычисления в массиве В(8) суммы четных элементов.        
Гость
Ответ(ы) на вопрос:
Гость
1) Ввод чисел в массив: program vvod_mass; var a: array[1..12] of integer; i: integer; begin for i:=1 to 12 do begin write('a[', i, ']='); readln(a[i]); end; end. 2) program otric; var a: array[1..10] of integer; i,n: integer; begin randomize; for i:=1 to 10 do begin a[i]:=-10+random(21); writeln(a[i]); end; for i:=1 to 10 do if a[i]<0 then inc(n); write('Кол-во отрицательных чисел массива: ', n); end. 3) program chetniy; var a: array[1..8] of integer; i,n: integer; begin randomize; for i:=1 to 8 do begin a[i]:=-10+random(21); writeln(a[i]); end; for i:=1 to 8 do if a[i] mod 2 = 0 then inc(n); write('Кол-во отрицательных чисел массива: ', n); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы