Нужно составить программу, которая сможет вывести число, месяц и день недели, которые наступят через K дней, начиная с первого января 2008 года. Напомним, что это был вторник.Язык : Паскаль. Целое число K (0 меньше = K меньше...

Нужно составить программу, которая сможет вывести число, месяц и день недели, которые наступят через K дней, начиная с первого января 2008 года. Напомним, что это был вторник. Язык : Паскаль. Целое число K (0 <= K <= 1000) Пример: ------------------------------------------------------------------------------------- Входа:                     |                Выхода:                           0                              |                Tuesday, 01.01 5                              |                Sunday, 06.01  ------------------------------------------------------------------------------------
Гость
Ответ(ы) на вопрос:
Гость
// Я очень, невероятно не люблю изобретать велосипеды //Поэтому воспользуемся уже встроенным типом DataTime //Pascal ABC.NET Версия 2.2 Сборка 790 uses system; var k:integer; startSys:DateTime; //сабж m,d:string; begin; readln(k); startSys:=startSys.AddYears(2007); //добавляет года к старту, отсчёт от 1 startSys:=startSys.AddDays(k); //добавляет кол-во дней //тип сам определяет високосный год или нет writeln(startSys.DayOfWeek,', ',startSys.Day,'.',startSys.Month); //вывод end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы