Очень срочно 20 баллов1. Составьте программу, которая формирует мас- сив из шестнадцати случайных целых чисел от-20 до 20 и: a) находит элементы с нулевыми значениями, б) находит индексы четных элементов; в) подсчитывает количе...
Очень срочно
20 баллов
1. Составьте программу, которая формирует мас- сив из шестнадцати случайных целых чисел от-20 до 20 и: a) находит элементы с нулевыми значениями, б) находит индексы четных элементов; в) подсчитывает количество отрицательных эл ементов г) определяет, есть ли в этом массиве хотя бы одно число, кратное трем, д) находит в этом массиве индексы алементов значения которых кратны трем.
На экран выводятся исходный массив и найденные элементы
Ответ(ы) на вопрос:
program qq_a;
uses CRT;
const N=16;
var a:array[1..N] of integer; i:integer;
begin
for i:=1 to N do
begin
a[i]:=random((41)-20);
end;
for i:=1 to N do
if a[i]=0 then
writeln('a[',i,']=0')
else
writeln('Нет нулевых элементов');
end.
Не нашли ответ?
Похожие вопросы