Очень срочно. даю 100 пунктов. Pascal ABC. Если не сдам, будет 3 за четверть((((((((((((((   Написать программу, которая сортирует массив ПО УБЫВАНИЮ и ищет в нем элемент, равный X (это число вводится с клавиатуры). Использоват...

Очень срочно. даю 100 пунктов. Pascal ABC. Если не сдам, будет 3 за четверть((((((((((((((   Написать программу, которая сортирует массив ПО УБЫВАНИЮ и ищет в нем элемент, равный X (это число вводится с клавиатуры). Использовать двоичный поиск.
Гость
Ответ(ы) на вопрос:
Гость
var l, i , n, z, j,r,m, key: integer; a: array [1..100] of integer; begin readln(key, n); for i := 1 to n do read(a[i]); for i := 1 to n-1 do for j := i to n do if a[i] < a[j] then begin z := a[i]; a[i] := a[j]; a[j] := z end; l := 1; r := n + 1; While l < r - 1 do begin m := (l + r) div 2; if a[m] < key then r := m else l := m; end; if a[l] = key then WriteLn(l); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы