Очень срочно! Нужна ваша помощь! Написать программу на паскале: сформировать матрицу и найти наименьшее среди средних арифметических элементов ее столбцов.( В ответе достаточно рабочего кода)
Очень срочно! Нужна ваша помощь!
Написать программу на паскале: сформировать матрицу и найти наименьшее среди средних арифметических элементов ее столбцов.( В ответе достаточно рабочего кода)
Ответ(ы) на вопрос:
//PascalABC.Net 3.0, сборка 1064
type
IntArray = array of integer;
var
rows, cols: integer;
M: array of IntArray;
begin
Write('Количество строк и столбцов матрицы: '); Read(rows, cols);
var Avg: array of double := new double[cols];
M := new IntArray[rows];
SetLength(Avg, cols);
for var i := 0 to rows - 1 do
begin
M[i] := ArrRandom(cols, -25, 25);
M[i].Println(#9)
end;
for var j := 0 to cols - 1 do
Avg[j] := Range(0, rows - 1).Select(x -> M[x, j]).Average;
Writeln('Наименьшее среднее по столбцам равно ', Avg.Min)
end.
Тестовое решение:
Количество строк и столбцов матрицы: 5 8
-22 -8 12 7 3 -18 8 22
2 -16 17 -13 -10 0 -19 2
20 -21 -6 13 2 -20 25 24
-7 -3 -2 -10 -2 8 18 23
4 -21 -8 8 23 -12 -13 -5
Наименьшее среднее по столбцам равно -13.8
Не нашли ответ?
Похожие вопросы