Очень срочно Требовалось написать программу, которая вводит с клавиатуры координаты точки на плоскости (x, y – действительные числа) и определяет принадлежность точки заштрихованной области, включая ее границы. Программист т...
Очень срочно Требовалось
написать программу, которая вводит с клавиатуры координаты точки на плоскости
(x, y – действительные числа) и определяет принадлежность точки заштрихованной
области, включая ее границы. Программист торопился и написал программу
неправильно. Вот она:
var x, y: real;
begin
readln(x, y);
if x >= 0 then
if y <= 1 then
if (x*x + y*y <= 1) and (y >= x-1) then
write('принадлежит')
else
write('не принадлежит');
end.
надо ёё зделать правильно
Ответ(ы) на вопрос:
Рисунка нету, так что предположу, что в программе верное условие.
---
var x,y:real;
begin
readln(x, y);
if (x>=0) and (y<=1)
and (x*x + y*y <= 1)
and (y >= x-1) then
write('принадлежит')
else write('не принадлежит');
end.
Не нашли ответ?
Похожие вопросы