Оценки, полученные спортсменом в соревнованиях по фигурному катанию (в баллах), хранятся в массиве из 18 элементов. В первых шести элементах записаны оценки по обязательной программе, седьмом—двенадцатом – по короткой программе...

Оценки, полученные спортсменом в соревнованиях по фигурному катанию (в баллах), хранятся в массиве из 18 элементов. В первых шести элементах записаны оценки по обязательной программе, седьмом—двенадцатом – по короткой программе, в остальных – по произвольной программе. Выяснить, по какому виду программы спортсмен показал лучший результат. написать программу в паскале буду очень благодарна
Гость
Ответ(ы) на вопрос:
Гость
Var  a:array[1..18] of integer;  i,n,n2,max:integer; Begin for i:=1 to 18 do Begin  case i of  1..6:begin Write('Введите ',i,'-ую оценку по обязательной программе '); Readln(a[i]); n:=n+a[i]; if i=6 then Begin max:=n; n:=0; n2:=1; End; End;  7..12:Begin Write('Введите ',i-6,'-ую оценку по короткой программе '); Readln(a[i]); n:=n+a[i]; if i=12 then Begin if n>max then Begin max:=n; n2:=2;End; n:=0; End; End;  13..18:Begin Write('Введите ',i-12,'-ую оценку по произвольной программе '); Readln(a[i]); n:=n+a[i]; if i=18 then Begin if n>max then Begin max:=n; n2:=3;End; n:=0; End; End;  end;  end;  case n2 of  1: write('Лучшая оценка по обязательной программе = ',max);  2: write('Лучшая оценка по короткой программе = ',max);  3: write('Лучшая оценка по произвольной программе = ',max);  End; End.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы