Pascal ABC Напишите программу, которая определяет количество элементов, сумма цифр которых четна. Формат ввода Программа получает на вход последовательность целых чисел, заканчивающаяся нулем (0 - признак окончания ввода). Форм...

Pascal ABC Напишите программу, которая определяет количество элементов, сумма цифр которых четна. Формат ввода Программа получает на вход последовательность целых чисел, заканчивающаяся нулем (0 - признак окончания ввода). Формат вывода Выведите одно число – количество чисел, сумма цифр которых четна Пример Ввод Вывод 2 4 3 4 1444 4 5 136 0
Гость
Ответ(ы) на вопрос:
Гость
Program n1; var a,k: integer; function summa( n: integer ): integer; var s: integer; begin s:=0; while n>0 do begin s:=s+n mod 10; n:=n div 10; end; summa:=s; end; begin k:=0; write('введите 1 число: '); readln(a); if (summa(a) mod 2=0) and(a<>0) then k:=k+1; while a<>0 do begin write('введите следущее число: '); readln(a); if (summa(a) mod 2=0) and(a<>0) then k:=k+1; end; writeln('количество: ',k); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы