PASCAL ABCНапишите программу, которая определяет правильность записи целого числа в восьмеричной системе счисления. Формат входных данных На вход программы поступает символьная строка. Формат выходных данных Программа должна вы...
PASCAL ABCНапишите программу, которая определяет правильность записи целого числа в восьмеричной системе счисления.
Формат входных данных
На вход программы поступает символьная строка.
Формат выходных данных
Программа должна вывести ответ 'YES', если строка представляет собой правильную запись целого числа в восьмеричной системе счисления, и 'NO', если запись ошибочна.
Ответ(ы) на вопрос:
var value, error: integer;
begin
var s:=readstring ('Введите строку: ');
val (s, value, error);
if (error<>0) or ('9' in s) or ('8' in s) then write ('NO') else write ('YES');
end.
Не нашли ответ?
Похожие вопросы