PASCALНаписать программу для нахождения принадлежности точки с координатами x,y заштрихованной области
PASCAL
Написать программу для нахождения принадлежности точки с координатами x,y заштрихованной области
Ответ(ы) на вопрос:
const pi=3.14;var x,y,y1,y2:real;beginreadln(x,y);y1:=-x+1;y2:= sin(x);if (y1>=0) and (x>=1) thenif (y2<=1) and (x<=pi) then writeln('Принадлежит')else writeln('Не принадлежит')else writeln('Не принадлежит');end.
var x, y: real;
begin readln(x, y);
if (y>=0) and (y<=sinx) and (x>=1-y) and (x<=Pi) then
writeln('принадлежит')
else writeln('не принадлежит');
readln;
end.
Не нашли ответ?
Похожие вопросы