(Pascal)составить программу, которая определяет встречаются ли в значении строковой величины два подряд идущих одинаковых символа
(Pascal)составить программу, которая определяет встречаются ли в значении строковой величины два подряд идущих одинаковых символа
Ответ(ы) на вопрос:
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString('->');
var c:=s[1];
for var i:=2 to s.Length do
if s[i]=c then begin Writeln(c,' - повторяющийся символ'); exit end
else c:=s[i];
Writeln('Повторяющихся символов нет')
end.
Пример
-> переезд
е - повторяющийся символ
Не нашли ответ?
Похожие вопросы