Паскаль ABC NET Составить программу решения a*x+b=c Очень прошу!! Желательно короче
Паскаль ABC NET
Составить программу решения
a*x+b=c
Очень прошу!!
Желательно короче
Ответ(ы) на вопрос:
Гость
//PascalABC.NET 3.0
begin
var a := ReadReal('a =');
var b := ReadReal('b =');
var c := ReadReal('c =');
b -= c;
if (a = 0) and (b = 0) then writeln('Уравнение имеет бесконченое множество корней')
else if a = 0 then writeln('Уравнение не имеет корней')
else writeln('Уравнение имеет один корень: ', -b / a);
end.
Не нашли ответ?
Похожие вопросы