Паскаль. Благодарю за помощь! С клавиатуры вводится символьная строка. Определите, сколько в ней цифр
Паскаль. Благодарю за помощь! С клавиатуры вводится символьная строка. Определите, сколько в ней цифр
Ответ(ы) на вопрос:
var s:string; k,i:integer;
begin
write('Введите строку:');
readln(s);
k:=0;
for i:=1 to length(s) do
if (s[i]>='0')and(s[i]<='9') then k:=k+1;
writeln('k = ',k);
end.
Пример:
Введите строку:
13 апреля 2016 г .
k = 6
// PascalABC.NET 3.1, сборка 1218 от 12.04.2016
begin
Write(ReadlnString('>').Where(c->c in ['0'..'9']).Count)
end.
Тестовое решение:
> Зде3сь спр14ята1ны 5 ци926ф5ры чи35сла8979 "пи"
15
Не нашли ответ?
Похожие вопросы