Паскаль) помогите пожалуйста) Напишите программу вычисления среднего геометрического модулей двух введенных с клавиатуры чисел. Программа должна использовать цикл while do. Условия выхода их цикла-значение числа, равное 999.
Паскаль) помогите пожалуйста)
Напишите программу вычисления среднего геометрического модулей двух введенных с клавиатуры чисел. Программа должна использовать цикл while do. Условия выхода их цикла-значение числа, равное 999.
Ответ(ы) на вопрос:
var a,b,sg: real;
begin
readln(a);
readln(b);
a:=abs(a); b:= abs(b);
sg:= sqrt(a*b);
writeln(sg);
end.
Вот программа вычисления средней геометрической. Но про цикл не понял...
Program Zadacha;
Var a, b, i: Integer;
c: Real;
Begin
Write('a = ');
ReadLn(a);
Write('b = ');
ReadLn(b);
c := Sqrt(Abs(a) * Abs(b));
i := 0;
While i < 999 Do
i := i + 1;
WriteLn('Результат: ', c:5:2);
ReadLn;
End.
Не нашли ответ?
Похожие вопросы