Паскаль Пусть вводится последовательность вещественных чисел, оканчивающаяся нулем и состоящая более чем из одного ненулевого элемента. Определите наибольшее число последовательности.
Паскаль
Пусть вводится последовательность вещественных чисел, оканчивающаяся нулем и состоящая более чем из одного ненулевого элемента. Определите наибольшее число последовательности.
Ответ(ы) на вопрос:
Гость
Попробуй так:
uses Crt;
var a, Max: real;
i: integer;
begin
ClrScr;
i:=0;
Repeat
i:=i+1;
Write ('a',i,'='); ReadLn (a);
if a<>0 then
begin
if a>Max then Max:=a;
end;
until a=0;
WriteLn;
WriteLn(' Max = ', Max:6:4);
ReadLn;
end.
Не нашли ответ?
Похожие вопросы