Паскаль срочно!!1 Напишите программу, которая вычисляет один из параметров газового состояния (Уравнение Менделеева-Клапейрона): р, V, Т, m- по задаваемым с клавиатуры значениям остальных параметров. R= 8.314 Дж/моль-К - универ...

Паскаль срочно!!1 Напишите программу, которая вычисляет один из параметров газового состояния (Уравнение Менделеева-Клапейрона): р, V, Т, m- по задаваемым с клавиатуры значениям остальных параметров. R= 8.314 Дж/моль-К - универсальная газовая постоянная; m- масса газа (кг); V - объем данной массы газа (м3); P- давление (Па); T- термодинамическая температура (К); M- масса одного моля газа (кг/моль).
Гость
Ответ(ы) на вопрос:
Гость
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016 // Внимание! Если программа не работает, обновите версию! const   R=8.314; begin   Writeln('Расчет параметров газового состояния');   Writeln('Введите обозначение величины, которую хотите найти:');   Writeln('p - давление, m- масса газа, V - объем массы газа,');   Writeln('T- термодинамическую температуру, иное - ОТКАЗ');   var c:=ReadlnChar;   if Pos(c,'pPmMVvTt')=0 then Writeln('Всего доброго!')   else begin     var M1,p,V,m,T:real;     M1:=ReadReal('Введите массу одного моля газа (кг/моль):');     case c of     'p','P':begin       m:=ReadReal('Введите массу газа (кг):');       V:=ReadReal('Введите объем массы газа (м3):');       T:=ReadReal('Введите термодинамическую температуру (К);');       Writeln('Давление p составляет ',m*R*T/M1/V:0:5,' Па')       end;     'm','M':begin       p:=ReadReal('Введите давление газа p (Па):');       V:=ReadReal('Введите объем массы газа (м3):');       T:=ReadReal('Введите термодинамическую температуру (К);');       Writeln('Масса газа m составляет ',p*V*M1/R/T:0:5,' кг')       end;     'V','v':begin       p:=ReadReal('Введите давление газа p (Па):');       m:=ReadReal('Введите массу газа (кг):');       T:=ReadReal('Введите термодинамическую температуру (К);');       Writeln('Объем массы газа V составляет ',m*R*T/M1/p:0:5,' м3')       end;     'T','t':begin       p:=ReadReal('Введите давление газа p (Па):');       m:=ReadReal('Введите массу газа (кг):');       V:=ReadReal('Введите объем массы газа (м3):');       Writeln('Термодинамическая температура составляет ',p*V*M1/m/R:0:1,' K')       end     end   end end. Пример Расчет параметров газового состояния Введите обозначение величины, которую хотите найти: p - давление, m- масса газа, V - объем массы газа, T- термодинамическую температуру, иное - ОТКАЗ m Введите массу одного моля газа (кг/моль): 28e-3 Введите давление газа p (Па): 96360 Введите объем массы газа (м3): 2e-3 Введите термодинамическую температуру (К); 298 Масса газа m составляет 0.00218 кг
Не нашли ответ?
Ответить на вопрос
Похожие вопросы