Паскаль. задается последовательность натуральных чисел. Найти среднее арифметических всех отрицательных чисел

Паскаль. задается последовательность натуральных чисел. Найти среднее арифметических всех отрицательных чисел
Гость
Ответ(ы) на вопрос:
Гость
Решение #1   var a:array[1..1000] of integer; s,i,k,N:integer; begin s:=0; k:=0; read(N); for i:=1 to N do read(a[i]); for i:=1 to N do if a[i]<0 then begin s:=s+a[i]; k:=k+1; end; writeln(s/k); end.   Решение #2;   var a,i,s,k,N:integer; begin k:=0; s:=0; read(N); for i:=1 to N do begin read(a); if a<0 then begin k:=k+1; s:=s+a; end; end; write(s/k); end.   Оба решение дают один результат, но первое сделан массивом, а второе простым перебором чисел.  Формат входных данных Задается натуральное число N Затем задается N целых чисел  Формат выходных данных  Целое число - среднее арифметическое всех отрицательных чисел  Пример Вход 5 1 -2 3 -4 5 Выход -3  Вопросы в ЛС
Не нашли ответ?
Ответить на вопрос
Похожие вопросы