Перестановка элементов массива Массив A(10) состоит из чисел 7, 8 и 9. Переставить эле?

Перестановка элементов массива Массив A(10) состоит из чисел 7, 8 и 9. Переставить эле??енты массива таким образом, чтобы сначала стояли все числа 8, потом – 7, а в конце – 9. (Примечание: Используется один массив, последний блок в программе должен быть: for i:=1 to 10 do write(a[i], ' '); ) Формат входных данных: В единственной строке входного файла 10 чисел разделенных пробелами. Формат выходных данных: 10 чисел разделенные пробелами.
Гость
Ответ(ы) на вопрос:
Гость
Var a:array[1..10]of integer; i,n7,n8,n9:integer; begin   for i:=1 to 10 do begin     read(a[i]);     if a[i] = 7 then n7+=1;     if a[i] = 8 then n8+=1;     if a[i] = 9 then n9+=1;   end;   for i:=1 to 10 do begin     if i<=n8 then a[i]:=8;     if (i>n8) and (i<=(n7+n8)) then a[i]:=7;     if i>(n7+n8) then a[i]:=9;   end;   for i:=1 to 10 do write(a[i],' '); end. Тестовое решение: 9 7 8 9 7 8 9 7 8 9 8 8 8 7 7 7 9 9 9 9
Не нашли ответ?
Ответить на вопрос
Похожие вопросы