ПЛАЧУ МНОГО БАЛЛОВ! Составьте программу для определения количества четных и нечетных цифр в записи данного натурального, пятизначного числа. (В обычном паскале)

ПЛАЧУ МНОГО БАЛЛОВ! Составьте программу для определения количества четных и нечетных цифр в записи данного натурального, пятизначного числа. (В обычном паскале)
Гость
Ответ(ы) на вопрос:
Гость
Var a,c,n : Longint; Begin   Readln(a);   c:=0; n:=0;   While a>0 do   Begin     If a mod 10 <> 0 then       If Odd(a mod 10) then Inc(n) else Inc(c);     a:=a div 10;   end;   Writeln('Чётных: ',c);   Writeln('Нечётных: ',n); end.
Гость
//PascalABC.NET (версия 3.1, сборка 1198 от 11.03.2016) var n,x,n1,n2: integer;//n1-кол-во четных, n2-нечетных begin   readln(n);   while n>0 do  begin   x:=n mod 10;   if x mod 2 = 0 then n1:=n1+1     else n2:=n2+1;   n:=n div 10;   end;   writeln('Четных: ',n1,'  Нечетных: ',n2); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы