Помогите 1.Определите значение переменной с после выполнения следующего фрагмента программы: a:=-2; b:=13; a:=b+a*3; if a 2.Наберите команды, которые выполняют следующие действия: а) ввод переменных x, y ...

Помогите 1.Определите значение переменной с после выполнения следующего фрагмента программы: a:=-2; b:=13; a:=b+a*3; if a 2.Наберите команды, которые выполняют следующие действия: а) ввод переменных x, y б) вывод переменной z в) описать переменную a целого типа, а переменные b, с вещественного типа г) увеличить переменную d на 20 д) переменной z присвоить сумму x и y 3.Допишите недостающие части программы для нахождения значения выражения w=12s+26b: PROGRAM PR1; … BEGIN READLN (S, B); … WRITELN (W); … 4.Запишите на языке Паскаль следующие условия: а) число f больше 105; д) число z меньше либо равно d; б) число а меньше 184; е) произведение чисел y и x больше либо равно сумме d и w; в) число w не равно 181; ж) разность чисел w и d меньше 88; г) число z неотрицательно; з) число f положительное 5. Запишите на языке Паскаль команду ветвления для решения следующей задачи: а) если число a не равно 21, то увеличить переменную a на 28, иначе уменьшить на 51 б) увеличить переменную a в 5 раз, если a - нечетное, иначе уменьшить на 12 6. Запишите на языке Паскаль команду цикла для решения следующей задачи: а) составить программу, которая вычисляет произведение первых 66 натуральных чисел (параметром цикла является переменная j, а произведение хранится в переменной p) б) составить программу, которая выводит на экран 7 раз в столбик слово: trud (параметром цикла является переменная n)
Гость
Ответ(ы) на вопрос:
Гость
1)      а:=b(13)+a(-2)*3=13+(-2*3)=13-6=7 2)      a) readln(а); readln(х); б) writeln(z) в)    var b,c : real; (чаще всего используется при нахождении вещественных чисел)         var a: integer; (чаще всего используется при нахождении вещественных чисел) г) if d = a(число, которому нужно прировнять, этот фрагмент цикла(если…,то ..иначе)) then d:=d+20; д) z := x + y; ( : = это знак присвоения) 3)  PROGRAM PR1; var w,s,b: integer; BEGIN READLN (S, B); w:= ((12*s) + (26*b)); WRITELN (W); end. 4) Запишите на языке Паскаль следующие условия: а) f >105 ; б)  a<184  ; в)  w<>181;   г)  z>0; д) z<=d; е) (y*x)>=(d+w); ж)  (w-d)<88; з) f>=1; 5. Запишите на языке Паскаль команду ветвления для решения следующей задачи: а) if  a<> 21 then a:=a+28 else a:=a-51; б) if  a mod  2=0 then a:=a+5 else a:=a-12; 6. Запишите на языке Паскаль команду цикла для решения следующей задачи: а)  PROGRAM PR1; var j,p: integer; BEGIN j:=1; p:=0; While j>=66 do BEGIN p:= p*j; j:=j+1: WRITELN (‘произведение чисел = ‘, p); end. б)   PROGRAM PR1; var n:integer; begin for n:=1 to 7 do writeln('trud'); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы